aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGerald Combs <gerald@wireshark.org>2023-01-10 18:04:34 -0800
committerGerald Combs <gerald@wireshark.org>2023-01-11 18:42:39 +0000
commit29ca9c289f6fddcc62a4c79027831c557045029e (patch)
tree0f4b4d242fd27102d58ea74cef185999236b6c19 /CMakeLists.txt
parent9c68879a27cdd617c9d05808b362a0066deb042a (diff)
macOS: Add an initial donation page to the .dmg
Add a donation page to the .dmg package.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt16
1 files changed, 15 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index bbe8de0772..16142132ac 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -3408,6 +3408,20 @@ if(ENABLE_APPLICATION_BUNDLE AND BUILD_wireshark)
${CMAKE_CURRENT_SOURCE_DIR}/packaging/macosx/Wireshark_read_me_first.adoc
)
+ set(_wireshark_donate "packaging/macosx/wireshark/Donate to the Wireshark Foundation.html")
+ ADD_CUSTOM_COMMAND(
+ OUTPUT
+ ${_wireshark_donate}
+ COMMAND ${ASCIIDOCTOR_EXECUTABLE}
+ --backend html
+ --out-file ${_wireshark_donate}
+ --attribute include-dir=${CMAKE_SOURCE_DIR}/docbook
+ --attribute min-macos-version=${MIN_MACOS_VERSION}
+ ${CMAKE_CURRENT_SOURCE_DIR}/packaging/macosx/Donate_to_the_Wireshark_Foundation.adoc
+ DEPENDS
+ ${CMAKE_CURRENT_SOURCE_DIR}/packaging/macosx/Donate_to_the_Wireshark_Foundation.adoc
+ )
+
set(_wireshark_dsym_installation "packaging/macosx/wireshark/Debugging symbols installation.html")
ADD_CUSTOM_COMMAND(
OUTPUT
@@ -3421,7 +3435,7 @@ if(ENABLE_APPLICATION_BUNDLE AND BUILD_wireshark)
${CMAKE_CURRENT_SOURCE_DIR}/packaging/macosx/Wireshark_dsym_installation.adoc
)
- add_custom_target(wireshark_dmg_readmes DEPENDS ${_wireshark_read_me_first} ${_wireshark_dsym_installation} )
+ add_custom_target(wireshark_dmg_readmes DEPENDS ${_wireshark_read_me_first} ${_wireshark_donate} ${_wireshark_dsym_installation} )
add_dependencies(wireshark_dmg_prep wireshark_dmg_readmes)
ADD_CUSTOM_TARGET( wireshark_dmg