aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGerald Combs <gerald@wireshark.org>2015-01-13 13:32:12 -0800
committerGerald Combs <gerald@wireshark.org>2015-01-14 19:53:47 +0000
commit242f711cfe4fd076f47ef35dfc6e42f7125c5116 (patch)
tree4be351ff6d3f6c89e602005f5ffa70b0f69156f3 /CMakeLists.txt
parent5b8fa72bdc81e10bce4ebc896f10853c73949276 (diff)
CMake: Update windeployqt discovery.
Update the comments and add a URL. Use HINTS, which is more correct according to the documentation. Change-Id: I82a7e2790dfa0b398e2b534f9f45851f55bdc0d2 Reviewed-on: https://code.wireshark.org/review/6536 Reviewed-by: Gerald Combs <gerald@wireshark.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt13
1 files changed, 7 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 7a64bcfc26..5abc3255b2 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1418,14 +1418,15 @@ if(BUILD_wireshark AND QT_FOUND)
if(WIN32 AND Qt5Core_FOUND)
# Use windeployqt to copy our required DLLs to the run path.
- # Ideally one of the modules in ${QTDIR}/lib/cmake/Qt5WinExtras
- # would give us the path to windeployqt. For that matter a
- # reliable path to qmake would be amazingly convenient. As it
- # is we derive the location from Qt5::qmake, which is provided
- # by Qt5Core.
+ # Ideally one of the modules in ${QTDIR}/lib/cmake would expose
+ # the path to windeployqt. For that matter having a reliable
+ # path to qmake would be *amazingly convenient*. We don't have
+ # either of those so we try to discover the path via Qt5Core.
+ # http://stackoverflow.com/questions/24650936/qt5-with-cmake-how-to-find-qt-translations-dir
+
get_target_property(_qmake_location Qt5::qmake IMPORTED_LOCATION)
get_filename_component(_qt_bindir "${_qmake_location}" DIRECTORY)
- find_program(_windeployqt windeployqt PATHS "${_qmake_location}")
+ find_program(_windeployqt windeployqt HINTS "${_qmake_location}")
if (NOT "${_windeployqt}" STREQUAL "_windeployqt-NOTFOUND")
add_custom_target(copy_qt_dlls ALL)
# Will we ever need to use --debug? Windeployqt seems to