aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGraham Bloice <graham.bloice@trihedral.com>2015-04-08 23:19:31 +0100
committerGraham Bloice <graham.bloice@trihedral.com>2015-04-09 09:57:36 +0000
commit08c223a53a3689ae9f07bd69681615284601c1fe (patch)
treea01ed5af6ddaef827d55bd63018c63a5c138d41a /CMakeLists.txt
parent054a1aab5095aef72334686d8033012634c2d61c (diff)
Cleanup CMake VS solution
Move the zlib artefacts into Libs\zlib "folder" Change-Id: Iddf0121fad3885553d908a51e9e07a7f676403fe Reviewed-on: https://code.wireshark.org/review/7993 Petri-Dish: Graham Bloice <graham.bloice@trihedral.com> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: Gerald Combs <gerald@wireshark.org> Reviewed-by: Graham Bloice <graham.bloice@trihedral.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ab24d93524..8c4bc807df 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -634,6 +634,11 @@ if(ENABLE_ZLIB)
add_subdirectory("${ZLIB_SRC_DIR}" "${CMAKE_BINARY_DIR}/zlib")
set(ZLIB_INCLUDE_DIR "${ZLIB_SRC_DIR}" "${CMAKE_BINARY_DIR}/zlib")
set(ZLIB_LIBRARY zlib)
+ # Annoyingly zlib also builds some other stuff we aren't interested in
+ set_target_properties(zlib PROPERTIES FOLDER "Libs/zlib")
+ set_target_properties(zlibstatic PROPERTIES FOLDER "Libs/zlib")
+ set_target_properties(example PROPERTIES FOLDER "Libs/zlib")
+ set_target_properties(minigzip PROPERTIES FOLDER "Libs/zlib")
endif()
set(PACKAGELIST ${PACKAGELIST} ZLIB)
endif()