aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJoerg Mayer <jmayer@loplof.de>2014-07-02 17:43:17 +0200
committerJörg Mayer <jmayer@loplof.de>2014-07-02 15:57:09 +0000
commit0041f36093f27f17a7a5f5469d06147c79383c99 (patch)
tree3e5da9c526d0439219be5580028923d927ad0c78 /CMakeLists.txt
parent65e3f5c25ee48e5b736ddbdf04fb2a31601ce8c1 (diff)
Make the flag testing logic for linker flags work like the compiler flag testing.
Change-Id: I2478417cbcd395247215f149978c5f0c874c9b3a Reviewed-on: https://code.wireshark.org/review/2779 Reviewed-by: Jörg Mayer <jmayer@loplof.de>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 783da38445..b25965ad11 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -423,7 +423,7 @@ foreach(THIS_FLAG ${WIRESHARK_LD_FLAGS})
set(V WS_LD_FLAG_VALID${C})
check_c_linker_flag(${${F}} ${V})
if (${${V}})
- set(WS_LINK_FLAGS ${WS_LINK_FLAGS} ${${F}})
+ set(WS_LINK_FLAGS "${WS_LINK_FLAGS} ${${F}}")
endif()
math(EXPR C "${C} + 1")
endforeach()