aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGerald Combs <gerald@wireshark.org>2017-08-28 16:10:25 -0700
committerMichael Mann <mmann78@netscape.net>2017-08-29 01:55:00 +0000
commitf8d0a7f003c2916f08092da01c737294f1944eb8 (patch)
tree73c218d2672ce04cc8ff5205107588e687e11529 /CMakeLists.txt
parenta303bc1f2982e59885c9787d3f81e1ced4b5f342 (diff)
CMake: We no longer support Visual C++ 2005 or 2008.
Change-Id: Ide3688366aa3c38d48ff29224dbfc0fdb7bf1b7a Reviewed-on: https://code.wireshark.org/review/23277 Reviewed-by: Gerald Combs <gerald@wireshark.org> Petri-Dish: Gerald Combs <gerald@wireshark.org> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: Michael Mann <mmann78@netscape.net>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 0 insertions, 7 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 0a94cc571f..159ccb2176 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1465,13 +1465,6 @@ gmx_test_large_files(GMX_LARGEFILES)
add_definitions( -DTOP_SRCDIR=\"${CMAKE_SOURCE_DIR}\" )
-if(WIN32)
- # Disable deprecation
- if(MSVC80 OR MSVC90)
- add_definitions(-D_CRT_SECURE_NO_DEPRECATE -D_CRT_NONSTDC_NO_DEPRECATE)
- endif()
-endif()
-
if (${GIT_EXECUTABLE})
set(GIT_BIN_PARAM "--git-bin ${GIT_EXECUTABLE}")
endif()