aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJaap Keuter <jaap.keuter@xs4all.nl>2019-06-13 06:33:55 +0200
committerAnders Broman <a.broman58@gmail.com>2019-06-13 18:03:02 +0000
commite8645f69d81919bae0f5f13b13e53d274dbd6678 (patch)
tree14aa8a2221923c38cbb28e5adae8a985f3ac80fc /CMakeLists.txt
parentb94047c606a53f405ea24ca5bf5161a74da7d4b9 (diff)
sharkd: link with libm because of Speex
When builing without the Speex library the build inserts its own files to handle the codec conversion. These however require sharkd to be linked against libm, for the sine function. Change-Id: I80b3fd67a346849480976c00280537b786780627 Reviewed-on: https://code.wireshark.org/review/33582 Reviewed-by: Vasil Velichkov <vvvelichkov@gmail.com> Petri-Dish: Jaap Keuter <jaap.keuter@xs4all.nl> Tested-by: Petri Dish Buildbot Reviewed-by: Anders Broman <a.broman58@gmail.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c7d40a6d30..be8de205c4 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -2420,6 +2420,7 @@ if(BUILD_sharkd)
${APPLE_SYSTEM_CONFIGURATION_LIBRARY}
${WIN_WS2_32_LIBRARY}
${SPEEXDSP_LIBRARIES}
+ ${M_LIBRARIES}
)
set(sharkd_FILES
#