aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexis La Goutte <alexis.lagoutte@gmail.com>2017-08-30 07:06:19 +0000
committerAlexis La Goutte <alexis.lagoutte@gmail.com>2017-08-30 09:51:34 +0000
commitdc64d738005a42aba8d4ba21e9f95c154530de64 (patch)
tree4dfe3ad0ae947d17c4726d57b3c448f95179f943 /CMakeLists.txt
parentb0f253e07c2a90e49166445d165432b4e4cfa17f (diff)
Revert "Add -Wused-but-marked-unused as an extra warning flag."
This reverts commit 1aaa904622245200c179d53d638bdf256cda71ab. Change-Id: I6c783ffa40e5df9a3174cf768906e6d89ad909ef Reviewed-on: https://code.wireshark.org/review/23303 Reviewed-by: Alexis La Goutte <alexis.lagoutte@gmail.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 0 insertions, 7 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 159ccb2176..5c0fb227b4 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -606,13 +606,6 @@ else()
# never enable this one with -Werror.
#
-Wbad-function-cast
-
- #
- # This causes some generated files to fail with -Werror;
- # fixing that would require the generator to figure
- # out in which functions use which parameters.
- #
- -Wused-but-marked-unused
)
set(CXX_EXTRA_WARN_FLAGS