aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJörg Mayer <jmayer@loplof.de>2012-02-17 16:59:14 +0000
committerJörg Mayer <jmayer@loplof.de>2012-02-17 16:59:14 +0000
commitd205085350663e7cb6b086226620151d8a3d868d (patch)
tree7bfc5fa00bc1d39709e69a8a0ca305124ea7e746 /CMakeLists.txt
parented68db6e5d989e6af1f14108051645ee80d806fe (diff)
Trying to fix the compile of ui/util.c on Windows by moving the
source file directly into the sources variable - there seems to be a subtle difference between ui/util.c and epan/crypt/md5.c svn path=/trunk/; revision=41052
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 60486204dc..29269b80f2 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -567,7 +567,6 @@ set(WIRESHARK_COMMON_SRC
svnversion.h
sync_pipe_write.c
timestats.c
- ui/util.c
tap-megaco-common.c
tap-rtp-common.c
version_info.c
@@ -689,6 +688,7 @@ if( (BUILD_wireshark AND GTK_FOUND) OR (BUILD_qtshark AND QT_FOUND) )
summary.c
tempfile.c
u3.c
+ ui/util.c
${SHARK_COMMON_CAPTURE_SRC}
${WIRESHARK_COMMON_SRC}
)
@@ -750,6 +750,7 @@ if(BUILD_tshark)
tempfile.c
tshark-tap-register.c
tshark.c
+ ui/util.c
${TSHARK_TAP_SRC}
${SHARK_COMMON_CAPTURE_SRC}
${WIRESHARK_COMMON_SRC}
@@ -769,6 +770,7 @@ if(BUILD_rawshark AND PCAP_FOUND)
set(rawshark_FILES
${WIRESHARK_COMMON_SRC}
rawshark.c
+ ui/util.c
)
add_executable(rawshark ${rawshark_FILES})
add_dependencies(rawshark svnversion)