aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJoão Valverde <joao.valverde@tecnico.ulisboa.pt>2017-09-05 17:18:00 +0100
committerJoão Valverde <j@v6e.pt>2017-09-06 08:10:56 +0000
commitd0a91b27f26762e9c998cc5e6fe71767de5d32c7 (patch)
tree9850efb16c84537dba93ee3d6ac8b186036ae00b /CMakeLists.txt
parent143bc04ca7c11b4f5a0feef4c01627c9aee6bcd4 (diff)
plugins: config.h must not be included by public headers
For a sane plugin build environment. Include config.h as the first header in the .c file instead. Fix by moving required compiler attribute macros to a new "ws_attributes.h" API header. Change-Id: I34f58a927f68c1a0e59686c14d214825149749e1 Reviewed-on: https://code.wireshark.org/review/23400 Petri-Dish: João Valverde <j@v6e.pt> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: João Valverde <j@v6e.pt>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt11
1 files changed, 0 insertions, 11 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b7c18e0937..3504d17a98 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -772,17 +772,6 @@ if( NOT CMAKE_C_COMPILER_ID MATCHES "MSVC")
endif()
endif()
-if(CMAKE_COMPILER_IS_GNUCC OR CMAKE_C_COMPILER_ID MATCHES "Clang")
- set (C_UNUSED "__attribute__((unused))" )
- set (WS_NORETURN "__attribute__((noreturn))")
-elseif(MSVC)
- set (C_UNUSED "")
- set (WS_NORETURN "__declspec(noreturn)")
-else()
- set (C_UNUSED "")
- set (WS_NORETURN "")
-endif()
-
set(WIRESHARK_LD_FLAGS
-Wl,--as-needed
# -flto