aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJoão Valverde <joao.valverde@tecnico.ulisboa.pt>2017-09-06 11:49:12 +0100
committerJoão Valverde <j@v6e.pt>2017-09-06 17:26:39 +0000
commitc6f99aea466319d02006808f35069da7f87a5c1b (patch)
tree3b9fd8d5e32a1ba98742a50122a5a8e35e2cafb6 /CMakeLists.txt
parent7b6296ac5affa85687e6af8f5000cd3ed18b7cd4 (diff)
CMake: Move CPACK remnants and remove stale comment
Move required variables for better context. Remove TODO comment. "To do" is "everything" to re-implement CPack because (incomplete) support was dropped in g0831becc1a. Change-Id: Ie21001940794e264527f35b5d4638830de02d97e Reviewed-on: https://code.wireshark.org/review/23410 Reviewed-by: João Valverde <j@v6e.pt>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt27
1 files changed, 9 insertions, 18 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 3504d17a98..1dfb3afa79 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -35,6 +35,15 @@ endif()
set(PROJECT_VERSION "${PROJECT_MAJOR_VERSION}.${PROJECT_MINOR_VERSION}.${PROJECT_PATCH_VERSION}${PROJECT_VERSION_EXTENSION}")
+# packaging information
+if(WIN32)
+ set(CPACK_PACKAGE_NAME Wireshark)
+else()
+ set(CPACK_PACKAGE_NAME wireshark)
+endif()
+
+set(CPACK_PACKAGE_VERSION "${PROJECT_VERSION}")
+
message(STATUS "Generating build using CMake ${CMAKE_VERSION}")
if(WIN32)
# Needed for GREATER_EQUAL operator
@@ -1064,24 +1073,6 @@ endforeach()
# Provide Windows system lib names
include( UseWinLibs )
-#packaging information
-# XXX The CMake documentation recommends setting CPACK_PROJECT_CONFIG_FILE
-# instead.
-if(WIN32)
- # To do:
- # - Add WinPCap
- # - Add USBPcap
- # - Add CLI DLLs
- # - Add common (Glib, etc) DLLs
- # - Add Qt DLLs
- # - Add
- set(CPACK_PACKAGE_NAME Wireshark)
-else()
- set(CPACK_PACKAGE_NAME wireshark)
-endif()
-
-set(CPACK_PACKAGE_VERSION "${PROJECT_VERSION}")
-
# dist target that prepares source dir
add_custom_target(dist
COMMAND "${CMAKE_COMMAND}"