aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJoão Valverde <joao.valverde@tecnico.ulisboa.pt>2017-09-06 11:55:40 +0100
committerJoão Valverde <j@v6e.pt>2017-09-06 17:26:46 +0000
commitc1ef4693de99e56e182f7e8406f08a734e2e43b5 (patch)
tree74e42cca23d2a5527efa979c25661eac61d35a3a /CMakeLists.txt
parentc6f99aea466319d02006808f35069da7f87a5c1b (diff)
CMake: Make plugin installation path use PLUGIN_INSTALL_LIBDIR
Change-Id: I47f248f6ef56aba400054fa3ade2bf4d29eeb895 Reviewed-on: https://code.wireshark.org/review/23411 Petri-Dish: João Valverde <j@v6e.pt> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: João Valverde <j@v6e.pt>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 5 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1dfb3afa79..c57f4f7a47 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1355,10 +1355,12 @@ if(LIBSSH_FOUND)
endif()
# Directory where plugins and Lua dissectors can be found.
+set(PLUGIN_VERSION_DIR "plugins/${CPACK_PACKAGE_VERSION}")
+set(PLUGIN_INSTALL_LIBDIR "${CMAKE_INSTALL_LIBDIR}/${CPACK_PACKAGE_NAME}/${PLUGIN_VERSION_DIR}")
if (WIN32)
- set(PLUGIN_INSTALL_DIR "plugins/${CPACK_PACKAGE_VERSION}")
+ set(PLUGIN_INSTALL_DIR "${PLUGIN_VERSION_DIR}")
else ()
- set(PLUGIN_INSTALL_DIR "${CMAKE_INSTALL_PREFIX}/${CMAKE_INSTALL_LIBDIR}/${CPACK_PACKAGE_NAME}/plugins/${CPACK_PACKAGE_VERSION}")
+ set(PLUGIN_INSTALL_DIR "${CMAKE_INSTALL_PREFIX}/${PLUGIN_INSTALL_LIBDIR}")
endif()
# Location of our plugins. PLUGIN_DIR should allow running
@@ -1465,7 +1467,7 @@ set( prefix "${CMAKE_INSTALL_PREFIX}" )
set( exec_prefix "\${prefix}" )
set( libdir "\${exec_prefix}/${CMAKE_INSTALL_LIBDIR}" )
set( includedir "\${prefix}/include" )
-set( plugindir "\${libdir}/wireshark/plugins/${CPACK_PACKAGE_VERSION}" )
+set( plugindir "\${libdir}/wireshark/${PLUGIN_VERSION_DIR}" )
set(ICON_PATH "${CMAKE_SOURCE_DIR}/image/")
set( IN_FILES