aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDániel Bakai <bakaidl@gmail.com>2019-04-10 12:52:52 +0200
committerPeter Wu <peter@lekensteyn.nl>2019-04-22 15:24:46 +0000
commit9ce60b173bf17b7d20695d9dc1de050989019664 (patch)
tree95ec8b8554415ef2c80d6d9950cc9201c8d22c94 /CMakeLists.txt
parent51ac1047a7e434a0b2e264780b2fa31f1d986898 (diff)
Add brotli decompression support for HTTP and HTTP2 dissectors.
Change-Id: I9c09f55673187f6fee723fcd72798fb6b9958b03 Reviewed-on: https://code.wireshark.org/review/32745 Petri-Dish: Peter Wu <peter@lekensteyn.nl> Tested-by: Petri Dish Buildbot Reviewed-by: Peter Wu <peter@lekensteyn.nl>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt11
1 files changed, 11 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 6e3478f06b..df62819651 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1104,6 +1104,9 @@ ws_find_package(CARES ENABLE_CARES HAVE_C_ARES "1.5.0")
# Zlib compression
ws_find_package(ZLIB ENABLE_ZLIB HAVE_ZLIB)
+# Brotli compression
+ws_find_package(BROTLI ENABLE_BROTLI HAVE_BROTLI)
+
# LZ4 compression
ws_find_package(LZ4 ENABLE_LZ4 HAVE_LZ4)
@@ -1809,6 +1812,11 @@ if(WIN32)
list (APPEND OPTIONAL_DLLS "${ZLIB_DLL_DIR}/${ZLIB_DLL}")
list (APPEND OPTIONAL_PDBS "${ZLIB_DLL_DIR}/${ZLIB_PDB}")
endif(ZLIB_FOUND)
+ if (BROTLI_FOUND)
+ foreach( _dll ${BROTLI_DLLS} )
+ list (APPEND OPTIONAL_DLLS "${BROTLI_DLL_DIR}/${_dll}")
+ endforeach(_dll)
+ endif(BROTLI_FOUND)
# With libs downloaded to c:/wireshark-win64-libs this currently
# (early 2018) expands to about 1900 characters.
@@ -2756,6 +2764,9 @@ if(RPMBUILD_EXECUTABLE)
if (SYSTEMD_FOUND)
list(APPEND _rpmbuild_with_args --with sdjournal)
endif()
+ if (BROTLI_FOUND)
+ list(APPEND _rpmbuild_with_args --with brotli)
+ endif()
execute_process(
COMMAND ${PERL_EXECUTABLE}