aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGerald Combs <gerald@wireshark.org>2017-08-11 12:43:48 -0700
committerAnders Broman <a.broman58@gmail.com>2017-08-15 14:48:29 +0000
commit719adb4fdc61e5187efefdfeb25a41d60d40be7f (patch)
tree5fa55129c5dd026b006e5ea58256b8278c484843 /CMakeLists.txt
parentf4ca61220aa65e42d880c947ce9c01dfe5bc8d4b (diff)
Convert README to README.md.
Convert the contents of the top-level README to Markdown and give it a .md extension. Most of our documentation is plain text or AsciiDoc, but the top-level README file in a Git repository is special in that many online browsers will show the README contents along with the directory listing and those browsers tend to favor Markdown. This is true of GitHub (which we're currently mirroring to), Gerrit via its Gitiles plugin (which we're not yet using but likely will), and other places. Add "foreign" to AM_INIT_AUTOMAKE. There is probably a joke to be made here about the FSF and border walls. Change-Id: I87c306d74864e1f0a432225b160a1b4483ee946c Reviewed-on: https://code.wireshark.org/review/23049 Reviewed-by: Gerald Combs <gerald@wireshark.org> Petri-Dish: Gerald Combs <gerald@wireshark.org> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: Anders Broman <a.broman58@gmail.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1e6e0b4f7f..9efbe0ee95 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1678,7 +1678,8 @@ if (BUILD_xxx2deb)
endif()
if(WIN32)
- set(TEXTIFY_FILES COPYING NEWS README README.windows)
+ set(INSTALL_FILES README.md ${INSTALL_FILES})
+ set(TEXTIFY_FILES COPYING NEWS README.windows)
foreach(_text_file ${TEXTIFY_FILES})
set(INSTALL_FILES ${CMAKE_BINARY_DIR}/${_text_file}.txt ${INSTALL_FILES})
endforeach()