aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJoão Valverde <joao.valverde@tecnico.ulisboa.pt>2019-01-30 23:56:54 +0000
committerJoão Valverde <j@v6e.pt>2019-07-21 15:54:41 +0000
commit6e5ba74b31e5053c0ba0f3eaa79ff97d03eb5595 (patch)
treef1dcb909bf5fd4a5154af20d58b559e39c0d4eee /CMakeLists.txt
parentcdac470a60a0fd4ac871072f732a13038e691e73 (diff)
Remove ABI compliance checker code.
It's broken, unmaintained, poorly implemented and obsoleted by saner debug-info methods. Note: To do the compliance check properly would require much more extensive work to clearly define public and private interfaces (without manual bookeeping of files or symbols either, of course, because who would want that...). Change-Id: Ib801f3c152ca2369f95ca1f4af4d37cd8cc7c47a Reviewed-on: https://code.wireshark.org/review/33928 Petri-Dish: João Valverde <j@v6e.pt> Tested-by: Petri Dish Buildbot Reviewed-by: Peter Wu <peter@lekensteyn.nl> Reviewed-by: João Valverde <j@v6e.pt>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 0 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index cce671d7db..ca8c3dc004 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1416,10 +1416,6 @@ set(DATAFILE_DIR ${_datafile_dir} CACHE INTERNAL "Build time data file location.
# learn about the directory location.
add_subdirectory( wsutil )
-if(NOT WIN32)
- add_custom_target(dumpabi DEPENDS dumpabi-libwireshark dumpabi-libwiretap dumpabi-libwsutil)
-endif()
-
if(BUILD_wireshark AND QT_FOUND)
add_subdirectory( ui/qt )
endif()