aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGerald Combs <gerald@wireshark.org>2017-10-04 16:27:08 -0700
committerAnders Broman <a.broman58@gmail.com>2017-10-06 04:33:55 +0000
commit6172627534168bb31415fa31a7cecdb15bcca4ab (patch)
tree3804d72fe123a3c0e9fb1137a662207a0d4f3a5d /CMakeLists.txt
parentae794fc5f24e893b20f4161ac3cfb20e018e9b96 (diff)
Make osx-app.sh a configured file and remove Autotools targets.
Rename osx-app.sh to osx-app.sh.in and add the version to the plugin path at configure time. Instead up updating Autotools accordingly just remove the macOS packaging targets. gf61c381b5a removed support for Autotools in osx-app.sh and if anyone wants to build macOS packages I'd prefer that they use the same toolchain as the buildbot. Change-Id: Ide5205265bf8859a85b1afab68fa8f8285952bd3 Reviewed-on: https://code.wireshark.org/review/23839 Reviewed-by: Anders Broman <a.broman58@gmail.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b0370a9a33..7bafe80dec 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1492,6 +1492,7 @@ set( IN_FILES
image/wiretap.rc.in
image/wireshark.exe.manifest.in
packaging/macosx/Info.plist.in
+ packaging/macosx/osx-app.sh.in
packaging/macosx/osx-dmg.sh.in
packaging/macosx/Wireshark_package.pmdoc/index.xml.in
randpkt_core/doxygen.cfg.in
@@ -2935,7 +2936,7 @@ if(ENABLE_APPLICATION_BUNDLE)
set_target_properties(app_bundle PROPERTIES FOLDER "Copy Tasks")
add_custom_command(TARGET app_bundle
POST_BUILD
- COMMAND "${CMAKE_SOURCE_DIR}/packaging/macosx/osx-app.sh"
+ COMMAND "${CMAKE_BINARY_DIR}/packaging/macosx/osx-app.sh"
WORKING_DIRECTORY "${CMAKE_BINARY_DIR}/run"
)
add_dependencies(app_bundle ${PROGLIST})