aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJoão Valverde <joao.valverde@tecnico.ulisboa.pt>2019-02-03 01:07:26 +0000
committerAnders Broman <a.broman58@gmail.com>2019-06-11 20:27:21 +0000
commit57bb2b2a099fd1df57a37b3a93a07212167c59aa (patch)
tree1066544c6480123d022f77e76b508ef4e2c248e2 /CMakeLists.txt
parentde4463066667e5b3582eb7943c6bbd42d23059bf (diff)
Move codec plugins to /plugins
Change-Id: I56d61e2ef737e4326080d75a2302c73a4075e8a1 Reviewed-on: https://code.wireshark.org/review/33067 Reviewed-by: Anders Broman <a.broman58@gmail.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt17
1 files changed, 17 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 36adea0a6d..9b5c5d2917 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1433,9 +1433,26 @@ if(ENABLE_PLUGINS)
plugins/epan/wimaxasncp
plugins/epan/wimaxmacphy
plugins/wiretap/usbdump
+ plugins/codecs/G711
plugins/codecs/l16_mono
${CUSTOM_PLUGIN_SRC_DIR}
)
+ if(SPANDSP_FOUND)
+ list(APPEND PLUGIN_SRC_DIRS
+ plugins/codecs/G722
+ plugins/codecs/G726
+ )
+ endif()
+ if(BCG729_FOUND)
+ list(APPEND PLUGIN_SRC_DIRS
+ plugins/codecs/G729
+ )
+ endif()
+ if(SBC_FOUND)
+ list(APPEND PLUGIN_SRC_DIRS
+ plugins/codecs/sbc
+ )
+ endif()
# Build demo plugin, only if asked explicitly
if(ENABLE_PLUGIN_IFDEMO)