aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPeter Wu <peter@lekensteyn.nl>2017-08-27 22:07:55 +0100
committerGerald Combs <gerald@wireshark.org>2017-08-28 19:00:40 +0000
commit26de091d1be961570fade436de18f8422b89358f (patch)
tree8c3ad0d7f4a6a5a32394a88deca37ed33bcc8658 /CMakeLists.txt
parent464679f80f60173589b6f3476abc1e6177d1a43f (diff)
cmake: add ENABLE_NGHTTP2 option
Allow nghttp2 to be disabled, similar to --without-nghttp2. Change-Id: Id27ab12ef7c24a535824f762ce2feb20fba9e065 Reviewed-on: https://code.wireshark.org/review/23247 Petri-Dish: Peter Wu <peter@lekensteyn.nl> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: Gerald Combs <gerald@wireshark.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 6 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 07ec50dde9..0a94cc571f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -837,7 +837,7 @@ endif()
# - set HAVE_XXX
# The minimum package list
-set(PACKAGELIST Gettext M Git GLIB2 GMODULE2 GTHREAD2 GCRYPT LEX YACC Perl SH PythonInterp NGHTTP2)
+set(PACKAGELIST Gettext M Git GLIB2 GMODULE2 GTHREAD2 GCRYPT LEX YACC Perl SH PythonInterp)
set(LEX_OPTIONS REQUIRED)
set(GLIB2_OPTIONS REQUIRED)
set(GLIB2_FIND_OPTIONS REQUIRED)
@@ -964,6 +964,11 @@ if(ENABLE_SNAPPY)
set(PACKAGELIST ${PACKAGELIST} SNAPPY)
endif()
+# Enhanced HTTP/2 dissection
+if(ENABLE_NGHTTP2)
+ set(PACKAGELIST ${PACKAGELIST} NGHTTP2)
+endif()
+
# Embedded Lua interpreter
if(ENABLE_LUA)
set(PACKAGELIST ${PACKAGELIST} LUA)