aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGuy Harris <guy@alum.mit.edu>2017-08-27 14:19:39 -0700
committerGuy Harris <guy@alum.mit.edu>2017-08-27 21:20:45 +0000
commit1aaa904622245200c179d53d638bdf256cda71ab (patch)
tree9702dd99cf026bd3c06ad17d4da1e044d7bb2ac1 /CMakeLists.txt
parentd846a3e8b9908caa65d182b680efb82c56c8103f (diff)
Add -Wused-but-marked-unused as an extra warning flag.
We can't just turn it on yet, because that would require generators to know which generated functions use which parameters and mark only the unused ones as such. The generator that turns PIDL files into DCE RPC dissectors is one that would have to be fixed. Change-Id: I7b0e9b08de6e7e9e611143de7307d3323a5c913e Reviewed-on: https://code.wireshark.org/review/23249 Reviewed-by: Guy Harris <guy@alum.mit.edu>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 547cf21954..07ec50dde9 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -606,6 +606,13 @@ else()
# never enable this one with -Werror.
#
-Wbad-function-cast
+
+ #
+ # This causes some generated files to fail with -Werror;
+ # fixing that would require the generator to figure
+ # out in which functions use which parameters.
+ #
+ -Wused-but-marked-unused
)
set(CXX_EXTRA_WARN_FLAGS