aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorjmayer <jmayer@f5534014-38df-0310-8fa8-9805f1628bb7>2010-10-01 12:17:11 +0000
committerjmayer <jmayer@f5534014-38df-0310-8fa8-9805f1628bb7>2010-10-01 12:17:11 +0000
commit9dc1dde16e65cd6a11cf04f9813ed217684d5093 (patch)
treef7bb4c5b5e4207a767867351194793fb20959014 /CMakeLists.txt
parent68ece48abeb56a8c52b5a63758fe01e3a0f26478 (diff)
Fix for
https://bugs.wireshark.org/bugzilla/show_bug.cgi?id=4879 where the build would fail if no gtk2 development files were found. git-svn-id: http://anonsvn.wireshark.org/wireshark/trunk@34308 f5534014-38df-0310-8fa8-9805f1628bb7
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 5 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 78436bf6ea..b916f877b1 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -405,11 +405,14 @@ endforeach()
add_subdirectory( codecs )
add_subdirectory( epan )
-add_subdirectory( gtk )
add_subdirectory( tools/lemon )
add_subdirectory( wiretap )
add_subdirectory( wsutil )
+if(BUILD_wireshark and GTK2_FOUND)
+ add_subdirectory( gtk )
+endif()
+
# Basedir where to install guides
set(DOC_DIR "$ENV{docdir}")
message(STATUS "docdir: ${DOC_DIR}")
@@ -619,7 +622,7 @@ set(LIBEPAN_LIBS
${M_LIBRARIES}
)
-if(BUILD_wireshark)
+if(BUILD_wireshark and GTK2_FOUND)
set(wireshark_LIBS
ui
${GTK2_LIBRARIES}