aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGerald Combs <gerald@wireshark.org>2018-03-02 11:24:31 -0800
committerGerald Combs <gerald@wireshark.org>2018-03-02 21:59:21 +0000
commitf529ab5d0a27173ed68aa017a638b36b3dcf585f (patch)
tree7b580a462fa2e4f30f883b9c0654afc2ac99955b /CMakeLists.txt
parent84c7246e4c086f7bcfd7646a1d9f0c08c13dd41b (diff)
Remove the endpoint "Map" feature.
Remove the endpoint map and its button from the Qt and GTK+ UIs. It depends on GeoIP Legacy for coordinate information and those databases are being deprecated in favor of MaxMind DB. We *could* upgrade the code to use mmdbresolve, but according to https://dev.maxmind.com/geoip/geoip2/geolite2/ they're also going to remove coordinate information from GeoLite2: "In addition, in 2019, latitude and longitude coordinates in the GeoLite2 databases will be removed.* Latitude and longitude coordinates will continue to be provided in GeoIP2 databases. Please check back for updates." Change-Id: I43e1593d282a0f1aae897b1f4724117d1496b21e Reviewed-on: https://code.wireshark.org/review/26229 Petri-Dish: Gerald Combs <gerald@wireshark.org> Tested-by: Petri Dish Buildbot Reviewed-by: Gerald Combs <gerald@wireshark.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt10
1 files changed, 0 insertions, 10 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 406b34e388..00f3efdbb9 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1629,7 +1629,6 @@ set(INSTALL_FILES
colorfilters
dfilters
enterprises.tsv
- ipmap.html
manuf
pdml2html.xsl
services
@@ -2376,15 +2375,6 @@ if(BUILD_wireshark_gtk AND GTK_FOUND)
target_link_libraries(wireshark-gtk ${wireshark_gtk_LIBS})
install(TARGETS wireshark-gtk RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR})
- # Map for endpoints dialog
- ADD_CUSTOM_COMMAND(
- TARGET wireshark-gtk
- POST_BUILD
- COMMAND ${CMAKE_COMMAND} -E copy_if_different
- "${PROJECT_SOURCE_DIR}/ipmap.html"
- $<TARGET_FILE_DIR:wireshark-gtk>
- )
-
if(WIN32)
add_custom_target(copy_gtk_dlls)
set_target_properties(copy_gtk_dlls PROPERTIES FOLDER "Copy Tasks")