aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGerald Combs <gerald@wireshark.org>2018-04-16 14:49:55 -0700
committerAnders Broman <a.broman58@gmail.com>2018-04-17 03:46:05 +0000
commitad84eec866713b2f75e9b11a30468b81be7d3d5e (patch)
tree07eafb9d322bb6c7bfb39642e4a95c40fb1b9639 /CMakeLists.txt
parent1d030928ef88d630299e8e3531d9935ff1dfd342 (diff)
Switch the Doxygen API reference build to CMake.
Switch to a single Doyxgen configuration which was generated using a recent version of Doxygen and customized to suit our needs. Add wsar_html and wsar_html_zip targets to CMake. Update some Doxygen markup and documentation as needed. Change-Id: Ic8a424b292c35a26f74ae0b53322265683e56e69 Reviewed-on: https://code.wireshark.org/review/26976 Reviewed-by: Gerald Combs <gerald@wireshark.org> Petri-Dish: Gerald Combs <gerald@wireshark.org> Tested-by: Petri Dish Buildbot Reviewed-by: Anders Broman <a.broman58@gmail.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt26
1 files changed, 18 insertions, 8 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 063027c89e..48af698ecf 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1433,13 +1433,15 @@ set( libdir "\${exec_prefix}/${CMAKE_INSTALL_LIBDIR}" )
set( includedir "\${prefix}/include" )
set( plugindir "\${libdir}/wireshark/${PLUGIN_VERSION_DIR}" )
+# Doxygen variables
+file(GLOB TOP_LEVEL_SOURCE_LIST *.c *.cpp *.h)
+string (REPLACE ";" " " DOXYGEN_TOP_LEVEL_SOURCES "${TOP_LEVEL_SOURCE_LIST}")
+set(DOXYGEN_INPUT_DIRECTORY ${CMAKE_SOURCE_DIR})
+set(DOXYGEN_OUTPUT_DIRECTORY ${CMAKE_BINARY_DIR})
+
set(ICON_PATH "${CMAKE_SOURCE_DIR}/image/")
set( IN_FILES
- capchild/doxygen.cfg.in
- caputils/doxygen.cfg.in
doxygen.cfg.in
- doxygen_global.cfg
- epan/doxygen.cfg.in
image/libwireshark.rc.in
image/text2pcap.rc.in
image/capinfos.rc.in
@@ -1461,11 +1463,7 @@ set( IN_FILES
packaging/macosx/osx-app.sh.in
packaging/macosx/osx-dmg.sh.in
packaging/macosx/Wireshark_package.pmdoc/index.xml.in
- randpkt_core/doxygen.cfg.in
- ui/doxygen.cfg.in
- ui/qt/doxygen.cfg.in
wireshark.pc.in
- writecap/doxygen.cfg.in
)
foreach( _in_file ${IN_FILES} )
get_filename_component( _path ${_in_file} PATH )
@@ -3098,6 +3096,18 @@ install(
${CMAKE_INSTALL_MODULES_DIR}
)
+if (DOXYGEN_EXECUTABLE)
+ # API reference
+ add_custom_target(wsar_html
+ COMMAND ${DOXYGEN_EXECUTABLE} doxygen.cfg
+ )
+
+ add_custom_target(wsar_html_zip
+ COMMAND ${CMAKE_COMMAND} -E tar "cfv" "wsar_html.zip" --format=zip wsar_html
+ DEPENDS wsar_html wsar_html/index.html
+ )
+endif(DOXYGEN_EXECUTABLE)
+
# Test suite wrapper
if(ENABLE_APPLICATION_BUNDLE)
set(TEST_SH_BIN_DIR ${CMAKE_BINARY_DIR}/run)