aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGerald Combs <gerald@wireshark.org>2018-04-03 17:51:05 -0700
committerGerald Combs <gerald@wireshark.org>2018-04-04 16:09:10 +0000
commit1dd1b507d1f11a25b7726bfeb2dd75b06af61539 (patch)
treee625b2b04ff9b4de00eef349dcecc4da0c94c8de /CMakeLists.txt
parent5f5255ec54b95bc30a5cf4ef7664c993e24aa6e7 (diff)
CMake: Add a note about passing /external to Visual C++.
According to https://blogs.msdn.microsoft.com/vcblog/2017/12/13/broken-warnings-theory/ /external: will let is ignore warnings in external headers. Change-Id: Ib3000d7654ffab99a001b225ce6162aab88fc8fa Reviewed-on: https://code.wireshark.org/review/26734 Reviewed-by: Gerald Combs <gerald@wireshark.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1556be9afb..b0dde32c88 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -325,6 +325,8 @@ if( CMAKE_C_COMPILER_ID MATCHES "MSVC")
# See http://msdn.microsoft.com/en-us/library/dn785163.aspx
list(APPEND LOCAL_CFLAGS /Zo)
elseif(MSVC14)
+ # To do: Add /external:... See https://blogs.msdn.microsoft.com/vcblog/2017/12/13/broken-warnings-theory/
+ #
# /Zo Enhanced debugging of optimised code
# /utf-8 Set Source and Executable character sets to UTF-8
# VS2015(MSVC14): On by default when /Zi or /Z7 used.