aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGerald Combs <gerald@wireshark.org>2018-05-10 08:53:42 -0700
committerGerald Combs <gerald@wireshark.org>2018-05-11 16:11:14 +0000
commit17190a1ed29afaec671ba671ca66da0907c5be9c (patch)
tree25269a65ee777621561db203ab8a067c9681e6b9 /CMakeLists.txt
parentaedc1c7e4911347057bf69a5026a717fb8576064 (diff)
List some removed features in the release notes.
Require Qt 5.2 in CMakeLists.txt. Remove some old Qt 4 checks. Change-Id: I06814b3776b488d55a0ce1a26aaada43fb5e096c Reviewed-on: https://code.wireshark.org/review/27446 Petri-Dish: Gerald Combs <gerald@wireshark.org> Tested-by: Petri Dish Buildbot Reviewed-by: Gerald Combs <gerald@wireshark.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt24
1 files changed, 4 insertions, 20 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b4a2b4dee3..68492b3ca2 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1051,9 +1051,7 @@ string(REPLACE ";" " " _package_list "${PACKAGELIST}")
message(STATUS "Package List: ${_package_list}")
# Let's loop the package list
foreach(PACKAGE ${PACKAGELIST})
- if(${PACKAGE} STREQUAL "Qt4")
- set(PACKAGE_VAR "QT")
- elseif(${PACKAGE} STREQUAL "PythonInterp")
+ if(${PACKAGE} STREQUAL "PythonInterp")
set(PACKAGE_VAR "PYTHONINTERP")
elseif(${PACKAGE} STREQUAL "Gettext")
set(PACKAGE_VAR "GETTEXT")
@@ -1193,6 +1191,9 @@ if(SNAPPY_FOUND)
set(HAVE_SNAPPY 1)
endif()
if (Qt5Widgets_FOUND)
+ if (Qt5Widgets_VERSION VERSION_LESS 5.2)
+ message(FATAL_ERROR "Qt 5.2 or later is required.")
+ endif()
if (Qt5Widgets_VERSION VERSION_GREATER 5.6
AND (CMAKE_COMPILER_IS_GNUCC OR CMAKE_C_COMPILER_ID MATCHES "Clang"))
# Qt 5.7 and later require C++ 11. If our minmimu required CMake version
@@ -1229,23 +1230,6 @@ if (Qt5Widgets_FOUND)
# Squelch moc verbose "nothing to do" output
set(MOC_OPTIONS -nn)
endif()
-# If Qt4: QT_LIBRARIES and QT_INCLUDES are not set above. They require extra magic
-elseif(QT4_FOUND)
- include(${QT_USE_FILE})
- include_directories(${QT_INCLUDE_DIR})
- message(STATUS "Qt includes: ${QT_INCLUDE_DIR}")
- message(STATUS "Qt libs: ${QT_LIBRARIES}")
- if(QT_QTMULTIMEDIA_FOUND)
- include_directories(${QT_QTMULTIMEDIA_INCLUDE_DIR})
- message(STATUS "QtMultimedia includes: ${QT_INCLUDE_DIR}")
- set (QT_LIBRARIES ${QT_LIBRARIES} ${QT_QTMULTIMEDIA_LIBRARY})
- message(STATUS "QtMultimedia libs: ${QT_QTMULTIMEDIA_LIBRARY}")
- # That's the name autotools used
- set(QT_MULTIMEDIA_LIB 1)
- endif()
- if(WIN32 OR APPLE)
- message(FATAL_ERROR "Windows and macOS builds should use Qt5.")
- endif()
endif()
if(ENABLE_CHECKHF_CONFLICT)