aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGerald Combs <gerald@wireshark.org>2018-09-05 16:29:34 -0700
committerAnders Broman <a.broman58@gmail.com>2018-10-01 08:58:13 +0000
commitf69108b84e9f996641d9c920fffc19853115f56b (patch)
tree76d5045fb254b7f67c73a5ca0b12f55c0edda9a1 /CMakeLists.txt
parente1ef8f6a408cb5a017ff5d15deddcb2727ddf90e (diff)
Add a systemd Journal Export extcap.
Add an sdjournal extcap, which reads journal entries using the sd-journal API and dumps them as journal Export Format records. Change-Id: I17ccfa88ab5d053c16c869cd26e580d84022502e Reviewed-on: https://code.wireshark.org/review/29479 Reviewed-by: Gerald Combs <gerald@wireshark.org> Petri-Dish: Gerald Combs <gerald@wireshark.org> Tested-by: Petri Dish Buildbot Reviewed-by: Peter Wu <peter@lekensteyn.nl> Reviewed-by: Anders Broman <a.broman58@gmail.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c66d3e0f50..f0dc01c60a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -844,6 +844,10 @@ if(ENABLE_AIRPCAP)
set(PACKAGELIST ${PACKAGELIST} AIRPCAP)
endif()
+if(CMAKE_SYSTEM_NAME STREQUAL "Linux")
+ set(PACKAGELIST ${PACKAGELIST} Systemd)
+endif()
+
# Build the Qt GUI?
if(BUILD_wireshark)
# Untested, may not work if CMAKE_PREFIX_PATH gets overwritten