aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGerald Combs <gerald@wireshark.org>2019-03-18 16:32:54 -0700
committerGerald Combs <gerald@wireshark.org>2019-03-18 23:47:38 +0000
commita6da14982b2df222af81f89fa2db95b07fdf0388 (patch)
tree66323388056a639bbc29da01d5a2e41f9b49ba5c /CMakeLists.txt
parent36ba6b87c1545b5c93c498556ac0db74c5965a9c (diff)
NSIS: Fix our extra installer location.
We know the native Windows library path early on in the configure process. Use it to set the location of the Npcap and USBPcap installers instead of trying to derive it from the GLib DLL path. Change-Id: I02d48e115b374fb6080a7fe8017cba789254d5f1 Reviewed-on: https://code.wireshark.org/review/32475 Reviewed-by: Gerald Combs <gerald@wireshark.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 7c6d16c424..d79d2292f8 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -110,6 +110,8 @@ if(WIN32)
message(FATAL_ERROR "Windows setup (win-setup.ps1) failed.")
endif()
+ set(EXTRA_INSTALLER_DIR ${_ws_lib_dir})
+
# XXX Add a dependency on ${_ws_lib_dir}/current_tag.txt?
# Prepopulate some ConfigureChecks values. Compilation checks