aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGerald Combs <gerald@wireshark.org>2021-09-01 09:31:07 -0700
committerGerald Combs <gerald@wireshark.org>2021-09-01 09:31:07 -0700
commit5893d3cd095b4defde969624feefed12e38cea88 (patch)
tree0adbc3a3ad9a5eb4f0f5addcad26ce8beb53ae98 /CMakeLists.txt
parent43d2655f16ab70e97d35700f628e23720c8e58db (diff)
CMake: Fix tests.
Pass $<TARGET_FILE_DIR:wmem_test> to test.py, which should be the path for all of our built executables, instead of ...:tshark, which is the path for *some* of our built executables on macOS.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 93c4187438..a9eaf36b48 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -3553,7 +3553,7 @@ foreach(_group_name ${_test_group_list})
COMMAND ${CMAKE_COMMAND} -E env PYTHONIOENCODING=UTF-8
${PYTHON_EXECUTABLE} ${CMAKE_SOURCE_DIR}/test/test.py
--verbose
- --program-path $<TARGET_FILE_DIR:tshark>
+ --program-path $<TARGET_FILE_DIR:wmem_test>
${TEST_EXTRA_ARGS}
${_group_name}
)