aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGerald Combs <gerald@wireshark.org>2021-08-31 11:34:11 -0700
committerWireshark GitLab Utility <gerald+gitlab-utility@wireshark.org>2021-09-01 07:16:20 +0000
commit4d1357eebeb1c128b8153d176c57af0dea6dd531 (patch)
tree2c5202846882fcd5589f722e4c78a413d507b10b /CMakeLists.txt
parentb04165a57b7de7fa75d93e8f04e78aaf4e390030 (diff)
CMake: Get rid of WS_PROGRAM_PATH
Use the $<TARGET_FILE_DIR:tshark> generator expression instead.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 1 insertions, 8 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e8d844c735..93c4187438 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -412,13 +412,6 @@ endif()
# -fPIC/-fPIE (so set CMAKE_POSITION_INDEPENDENT_CODE to enable that).
set(CMAKE_POSITION_INDEPENDENT_CODE ON)
-# Path to our generated executables (or wrapper scripts)
-if(WIN32)
- set(WS_PROGRAM_PATH ./run/$<CONFIG>)
-else()
- set(WS_PROGRAM_PATH ./run)
-endif()
-
# Preprocessor definitions common to all compilers
set_property(DIRECTORY
PROPERTY COMPILE_DEFINITIONS
@@ -3560,7 +3553,7 @@ foreach(_group_name ${_test_group_list})
COMMAND ${CMAKE_COMMAND} -E env PYTHONIOENCODING=UTF-8
${PYTHON_EXECUTABLE} ${CMAKE_SOURCE_DIR}/test/test.py
--verbose
- --program-path ${WS_PROGRAM_PATH}
+ --program-path $<TARGET_FILE_DIR:tshark>
${TEST_EXTRA_ARGS}
${_group_name}
)