aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJoão Valverde <joao.valverde@tecnico.ulisboa.pt>2021-06-16 01:07:37 +0100
committerJoão Valverde <joao.valverde@tecnico.ulisboa.pt>2021-06-17 12:00:09 +0100
commit05ed76d4c04d97f0a9f42fc93dbf1d8eb9bd2c65 (patch)
tree561e5d61eb17cb071982d41c8d60f4f4c56a4f6b /CMakeLists.txt
parent790bbbe16dc65d2c7a7a378a89cd1836a3d8735b (diff)
wslog: Use plain format with "message" level
Try out a simpler format with the default log level. Don't display process and file/function information with "message" level (experimental).
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 540264bd0c..39720ab07c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -457,6 +457,8 @@ if( CMAKE_C_COMPILER_ID MATCHES "MSVC")
# in pcap-stdinc.h when compiling C++ files, e.g. the Qt UI
/DPSAPI_VERSION=1
/D_ALLOW_KEYWORD_MACROS
+ # https://stackoverflow.com/questions/37845163/what-is-the-purpose-of-microsofts-underscore-c-functions
+ /D_CRT_NONSTDC_NO_WARNINGS
)
if(NOT WIRESHARK_TARGET_PLATFORM STREQUAL "win64")