aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorKovarththanan Rajaratnam <kovarththanan.rajaratnam@gmail.com>2009-10-10 05:51:08 +0000
committerKovarththanan Rajaratnam <kovarththanan.rajaratnam@gmail.com>2009-10-10 05:51:08 +0000
commitee95203649cee2bd608142ef8907a05b0c178269 (patch)
tree2f8785cd83fc98edbbf41b561bd0ae95d90e45aa /CMakeLists.txt
parent142131917c85e823d28a707e0f86e2f945f86769 (diff)
Add tools/lemon/CMakeLists.txt which creates the lemon parser executable
svn path=/trunk/; revision=30461
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt12
1 files changed, 1 insertions, 11 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 2800f20c1e..e0f510793b 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -374,6 +374,7 @@ endif()
add_subdirectory( codecs )
add_subdirectory( epan )
add_subdirectory( gtk )
+add_subdirectory( tools/lemon )
add_subdirectory( wiretap )
add_subdirectory( wsutil )
@@ -401,17 +402,6 @@ ADD_CUSTOM_COMMAND(
${CMAKE_CURRENT_SOURCE_DIR}/make-version.pl
)
-# Create the necessary tools
-set(lemon_FILES
- tools/lemon/lemon.c
-)
-set(lemon_LIBS
- # Do we need something here on any platform?
-)
-add_executable(lemon ${lemon_FILES})
-target_link_libraries(lemon ${lemon_LIBS})
-# but don't install
-
register_tap_files(tshark-tap-register.c
${TSHARK_TAP_SRC}
)