aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJoerg Mayer <jmayer@loplof.de>2014-11-05 21:05:34 +0100
committerJörg Mayer <jmayer@loplof.de>2014-11-05 20:07:58 +0000
commit80b36cdbde90ac9639938a14e8fd90a79602666a (patch)
tree51ce8e1a4b761ab1d36675448b004a91e3f6d644 /CMakeLists.txt
parent547323b0ba3650a96e59c0b0d76ad2a3783db07d (diff)
Fix plugin search path: It was relative instead of absolute, resulting
in not found plugins (lib/wireshark/plugins/1.99.1). Change-Id: Ie81f3c4450789ff7e37c99e197b44e7df47d8df5 Reviewed-on: https://code.wireshark.org/review/5149 Reviewed-by: Jörg Mayer <jmayer@loplof.de>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 1 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b61f33360f..3f10ca2adb 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -777,8 +777,7 @@ ADD_CUSTOM_COMMAND(
if(ENABLE_PLUGINS)
set(HAVE_PLUGINS 1)
- set(PLUGIN_DIR "${DATAFILE_DIR}/plugins/${CPACK_PACKAGE_VERSION}")
- set(PLUGIN_INSTALL_DIR "${CMAKE_INSTALL_LIBDIR}/@CPACK_PACKAGE_NAME@/plugins/${CPACK_PACKAGE_VERSION}")
+ set(PLUGIN_INSTALL_DIR "${CMAKE_INSTALL_PREFIX}/${CMAKE_INSTALL_LIBDIR}/@CPACK_PACKAGE_NAME@/plugins/${CPACK_PACKAGE_VERSION}")
set(PLUGIN_SRC_DIRS
plugins/docsis
plugins/ethercat