aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGuy Harris <guy@alum.mit.edu>2014-08-02 16:26:50 -0700
committerGuy Harris <guy@alum.mit.edu>2014-08-02 23:27:28 +0000
commit2dd269091e52fa93485667dc69ddb401ec71297f (patch)
treeb0224da0f58a52f318ac7a34f8d0814ec262cfb1 /CMakeLists.txt
parent43eea3cfe8a1bd0f3e356068237afb6f25d6cfb5 (diff)
Note that the ...COMMON_FLAGS are for C and C++.
Change-Id: I0ef87b3b4aaed984a8a53660b36746345626583a Reviewed-on: https://code.wireshark.org/review/3373 Reviewed-by: Guy Harris <guy@alum.mit.edu>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b0373e37b7..e6fd590b61 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -197,6 +197,7 @@ if( CMAKE_C_COMPILER_ID MATCHES "MSVC")
)
else()
set(WIRESHARK_COMMON_FLAGS
+ # The following are for C and C++
# -O<X> and -g get set by the CMAKE_BUILD_TYPE
-Wall
-W
@@ -239,6 +240,7 @@ else()
)
set(WIRESHARK_EXTRA_COMPILER_COMMON_FLAGS
+ # The following are for C and C++
-pedantic
-Woverflow
#