aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAnders <anders.broman@ericsson.com>2018-04-04 10:00:06 +0200
committerAnders Broman <a.broman58@gmail.com>2018-04-04 17:02:02 +0000
commit9e02a0b65b87349814ab6aa9a1df9d6a930d0a3c (patch)
tree510ceca1c390a7ddd8388124fcd8116c1fdaf936 /CMakeLists.txt
parent1dd1b507d1f11a25b7726bfeb2dd75b06af61539 (diff)
CMake RPM build: Try to get rid of %globals in favor of %bcond.
Change-Id: I051fb722b0c4161b373f04a79288faa41a61c3cc Reviewed-on: https://code.wireshark.org/review/26735 Petri-Dish: Anders Broman <a.broman58@gmail.com> Tested-by: Petri Dish Buildbot Reviewed-by: Gerald Combs <gerald@wireshark.org> Reviewed-by: Anders Broman <a.broman58@gmail.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt12
1 files changed, 6 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b0dde32c88..092c4c6eb5 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -3046,22 +3046,22 @@ if(RPMBUILD_EXECUTABLE AND GIT_EXECUTABLE)
list(APPEND _rpmbuild_with_args --with lua)
endif()
if (LZ4_FOUND AND SNAPPY_FOUND)
- list(APPEND _rpmbuild_with_args --define "with_lz4_and_snappy 1")
+ list(APPEND _rpmbuild_with_args --with lz4_and_snappy)
endif()
if (CARES_FOUND)
- list(APPEND _rpmbuild_with_args --define "with_c_ares 1")
+ list(APPEND _rpmbuild_with_args --with c_ares)
endif()
if (SPANDSP_FOUND)
- list(APPEND _rpmbuild_with_args --define "with_spandsp 1")
+ list(APPEND _rpmbuild_with_args --with spandsp)
endif()
if (BCG729_FOUND)
- list(APPEND _rpmbuild_with_args --define "with_bcg729 1")
+ list(APPEND _rpmbuild_with_args --with bcg729)
endif()
if (LIBXML2_FOUND)
- list(APPEND _rpmbuild_with_args --define "with_libxml2 1")
+ list(APPEND _rpmbuild_with_args --with libxml2)
endif()
if (NGHTTP2_FOUND)
- list(APPEND _rpmbuild_with_args --define "with_nghttp2 1")
+ list(APPEND _rpmbuild_with_args --with nghttp2)
endif()
execute_process(