aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPascal Quantin <pascal.quantin@gmail.com>2018-03-07 22:10:31 +0100
committerPascal Quantin <pascal.quantin@gmail.com>2018-03-09 11:20:41 +0000
commit4e6d989df43af78439fccd24a176a14c534aea99 (patch)
treefe3e181869ec7deacc248bf1ae0f4c824761eddd /CMakeLists.txt
parent572f78a8610282151e7d165b11e0bf5092efbb5a (diff)
Add MaxMindDB 1.3.2 library to Windows
Change-Id: I328b6a05cc356be59ac63e80eae55a832bf76a47 Reviewed-on: https://code.wireshark.org/review/26347 Petri-Dish: Pascal Quantin <pascal.quantin@gmail.com> Reviewed-by: Pascal Quantin <pascal.quantin@gmail.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 4 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e4104f1a87..bb9097037f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1716,9 +1716,9 @@ if(WIN32)
if (CARES_FOUND)
list (APPEND OPTIONAL_DLLS "${CARES_DLL_DIR}/${CARES_DLL}")
endif(CARES_FOUND)
- if (GEOIP_FOUND)
- list (APPEND OPTIONAL_DLLS "${GEOIP_DLL_DIR}/${GEOIP_DLL}")
- endif(GEOIP_FOUND)
+ if (MAXMINDDB_FOUND)
+ list (APPEND OPTIONAL_DLLS "${MAXMINDDB_DLL_DIR}/${MAXMINDDB_DLL}")
+ endif(MAXMINDDB_FOUND)
if (LIBSSH_FOUND)
list (APPEND OPTIONAL_DLLS "${LIBSSH_DLL_DIR}/${LIBSSH_DLL}")
endif(LIBSSH_FOUND)
@@ -2926,6 +2926,7 @@ if (MAXMINDDB_FOUND)
add_executable(mmdbresolve ${mmdbresolve_FILES})
set_extra_executable_properties(mmdbresolve "Executables")
target_link_libraries(mmdbresolve ${mmdbresolve_LIBS})
+ target_include_directories(mmdbresolve PUBLIC ${MAXMINDDB_INCLUDE_DIR})
install(TARGETS mmdbresolve RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR})
endif()