aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGerald Combs <gerald@wireshark.org>2017-09-22 22:08:26 +0000
committerGerald Combs <gerald@wireshark.org>2017-09-22 22:08:41 +0000
commit3c8750dfb3b9cef1af2e29159782b443dfcd32ff (patch)
treee3b843e8609e9bfb638bb7a841a5b2e21a9ca804 /CMakeLists.txt
parented967507848f09ea4320c3bde36cf9020731793d (diff)
Revert "CMake: Print a warning if CCACHE_CPP2 is unset."
CCACHE_CPP2 / run_second_cpp is enabled by default in ccache 3.3 and later. (Unfortunately our builders have 3.2.4 installed.) This reverts commit ed1ecfb39cf0f3344810fabb7a1b855d373aa0a8. Change-Id: I3cc88fa70bb04db5ae254bc9b878ce379e47527d Reviewed-on: https://code.wireshark.org/review/23658 Reviewed-by: Gerald Combs <gerald@wireshark.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 0 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 5596cafa3a..d06049c5a2 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1291,10 +1291,6 @@ if(ENABLE_CCACHE AND (CMAKE_COMPILER_IS_GNUCC OR CMAKE_C_COMPILER_ID MATCHES "Cl
if(CCACHE_EXECUTABLE)
set_property(GLOBAL PROPERTY RULE_LAUNCH_COMPILE "${CCACHE_EXECUTABLE}")
set_property(GLOBAL PROPERTY RULE_LAUNCH_LINK "${CCACHE_EXECUTABLE}")
- # http://peter.eisentraut.org/blog/2014/12/01/ccache-and-clang-part-3/
- if(CMAKE_C_COMPILER_ID MATCHES "Clang" AND NOT DEFINED(ENV{CCACHE_CPP2}))
- message(WARNING "You're compiling using clang and ccache but CCACHE_CPP2 unset. This might produce unwanted warnings.")
- endif()
endif()
endif()