aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGerald Combs <gerald@wireshark.org>2018-03-13 10:15:25 -0700
committerGerald Combs <gerald@wireshark.org>2018-03-13 19:09:36 +0000
commit246f0bc0125eb2137781f5f8bfad783a2f7ac4cd (patch)
treeab379a95c861f64072d1099fb6ea687c639f6c45 /CMakeLists.txt
parentfa278335483da207150f8680811ad5f9545ab57d (diff)
Get rid of TestBigEndian and AC_C_BIGENDIAN.
Get rid of CMake's TestBigEndian and Autotools' AC_C_BIGENDIAN checks in favor of G_BYTE_ORDER. We use G_BYTE_ORDER elsewhere and TestBigEndian is noticeably slow on Windows. Change-Id: Idc1326294db9cbee8f6b6b11c2028fc4d19acbf0 Reviewed-on: https://code.wireshark.org/review/26462 Petri-Dish: Gerald Combs <gerald@wireshark.org> Tested-by: Petri Dish Buildbot Reviewed-by: Gerald Combs <gerald@wireshark.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 0 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index bb9097037f..d1f18da493 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1248,10 +1248,6 @@ endif()
include(ConfigureChecks.cmake)
-#Big or little endian ?
-include(TestBigEndian)
-test_big_endian(WORDS_BIGENDIAN)
-
# Global properties
set_property(GLOBAL PROPERTY USE_FOLDERS ON)