aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorStig Bjørlykke <stig@bjorlykke.org>2010-01-14 15:43:33 +0000
committerStig Bjørlykke <stig@bjorlykke.org>2010-01-14 15:43:33 +0000
commit229d8368bc101299d8f8de30d27f3e98c9efc6f7 (patch)
tree91f1e2b5aaaa9aa00bdc14f6ead070395254909b /CMakeLists.txt
parent0e3ba74734a19a7208b45fbb810930db2133f221 (diff)
Set correct locale in make-version.pl instead of in Makefiles.
Added back add_custom_command for svnversion.h. Removed unnecessary text2pcap_CLEAN_FILES. Fix indent for ps.c command. svn path=/trunk/; revision=31525
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt30
1 files changed, 18 insertions, 12 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 4ed2dd72c0..5f59791808 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -397,7 +397,16 @@ link_directories(
ADD_CUSTOM_TARGET(
svnversion ALL
- COMMAND LANG=C ${PERL}
+ COMMAND ${PERL}
+ ${CMAKE_CURRENT_SOURCE_DIR}/make-version.pl
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ DEPENDS
+ ${CMAKE_CURRENT_SOURCE_DIR}/make-version.pl
+)
+
+ADD_CUSTOM_COMMAND(
+ OUTPUT svnversion.h
+ COMMAND ${PERL}
${CMAKE_CURRENT_SOURCE_DIR}/make-version.pl
${CMAKE_CURRENT_SOURCE_DIR}
DEPENDS
@@ -409,14 +418,14 @@ register_tap_files(tshark-tap-register.c
)
ADD_CUSTOM_COMMAND(
- OUTPUT ps.c
- COMMAND ${PYTHON_EXECUTABLE}
- ${CMAKE_CURRENT_SOURCE_DIR}/tools/rdps.py
- ${CMAKE_CURRENT_SOURCE_DIR}/print.ps
- ps.c
+ OUTPUT ps.c
+ COMMAND ${PYTHON_EXECUTABLE}
+ ${CMAKE_CURRENT_SOURCE_DIR}/tools/rdps.py
+ ${CMAKE_CURRENT_SOURCE_DIR}/print.ps
+ ps.c
DEPENDS
- ${CMAKE_CURRENT_SOURCE_DIR}/tools/rdps.py
- ${CMAKE_CURRENT_SOURCE_DIR}/print.ps
+ ${CMAKE_CURRENT_SOURCE_DIR}/tools/rdps.py
+ ${CMAKE_CURRENT_SOURCE_DIR}/print.ps
)
if(UNIX)
@@ -658,9 +667,6 @@ if(BUILD_text2pcap)
set(text2pcap_FILES
text2pcap.c
)
- set(text2pcap_CLEAN_FILES
- ${text2pcap_FILES}
- )
add_lex_files(text2pcap_FILES
text2pcap-scanner.l
)
@@ -850,7 +856,7 @@ set(CLEAN_FILES
${rawshark_FILES}
${dftest_FILES}
${randpkt_FILES}
- ${text2pcap_CLEAN_FILES}
+ ${text2pcap_FILES}
${mergecap_FILES}
${capinfos_FILES}
${editcap_FILES}