aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJörg Mayer <jmayer@loplof.de>2010-10-01 12:17:11 +0000
committerJörg Mayer <jmayer@loplof.de>2010-10-01 12:17:11 +0000
commitb4b1ad99632e5269be6824a4a9ba5776e74380a0 (patch)
treef7bb4c5b5e4207a767867351194793fb20959014 /CMakeLists.txt
parent34c7218d1a20c00eb3c307dd879289c56fb20d5d (diff)
Fix for
https://bugs.wireshark.org/bugzilla/show_bug.cgi?id=4879 where the build would fail if no gtk2 development files were found. svn path=/trunk/; revision=34308
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 5 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 78436bf6ea..b916f877b1 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -405,11 +405,14 @@ endforeach()
add_subdirectory( codecs )
add_subdirectory( epan )
-add_subdirectory( gtk )
add_subdirectory( tools/lemon )
add_subdirectory( wiretap )
add_subdirectory( wsutil )
+if(BUILD_wireshark and GTK2_FOUND)
+ add_subdirectory( gtk )
+endif()
+
# Basedir where to install guides
set(DOC_DIR "$ENV{docdir}")
message(STATUS "docdir: ${DOC_DIR}")
@@ -619,7 +622,7 @@ set(LIBEPAN_LIBS
${M_LIBRARIES}
)
-if(BUILD_wireshark)
+if(BUILD_wireshark and GTK2_FOUND)
set(wireshark_LIBS
ui
${GTK2_LIBRARIES}