aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorLin Sun <lin.sun@zoom.us>2020-09-29 12:33:06 +0800
committerWireshark GitLab Utility <gerald+gitlab-utility@wireshark.org>2020-10-03 21:15:09 +0000
commit6136c719da4ec9b96c01adb4b0fd7f01af171688 (patch)
tree797542009e2f4d9d8453db1c7a97bb427ef4dfda /CMakeLists.txt
parentc1eb36b84b6fcfea93bfc087b280da60273b597d (diff)
RTP: opus playback
It's possible to play opus payload with libopus (https://opus-codec.org/). Closes #16882. Helped-by: Pascal Quantin <pascal.quantin@gmail.com> Signed-off-by: Lin Sun <lin.sun@zoom.us> Signed-off-by: Yuanzhi Li <ryanlee@mail.ustc.edu.cn>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt18
1 files changed, 18 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ccdac86879..f1534eab14 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1173,6 +1173,8 @@ ws_find_package(BCG729 ENABLE_BCG729 HAVE_BCG729)
ws_find_package(ILBC ENABLE_ILBC HAVE_ILBC)
+ws_find_package(OPUS ENABLE_OPUS HAVE_OPUS)
+
# CMake 3.9 and below used 'LIBXML2_LIBRARIES' as the name of the cache entry
# storing the find_library result. Transfer it to the new cache variable such
# that reset_find_package can detect and clear outdated cache variables.
@@ -1494,6 +1496,11 @@ if(ENABLE_PLUGINS)
plugins/codecs/iLBC
)
endif()
+ if(OPUS_FOUND)
+ list(APPEND PLUGIN_SRC_DIRS
+ plugins/codecs/opus_dec
+ )
+ endif()
if(SBC_FOUND)
list(APPEND PLUGIN_SRC_DIRS
plugins/codecs/sbc
@@ -1613,6 +1620,11 @@ set_package_properties(ILBC PROPERTIES
URL "https://github.com/TimothyGu/libilbc"
PURPOSE "Support for iLBC codec in RTP player"
)
+set_package_properties(OPUS PROPERTIES
+ DESCRIPTION "opus decoder"
+ URL "https://opus-codec.org/"
+ PURPOSE "Support for opus codec in RTP player"
+)
set_package_properties(LIBXML2 PROPERTIES
DESCRIPTION "XML parsing library"
URL "http://xmlsoft.org/"
@@ -1907,6 +1919,9 @@ if(WIN32)
if (ILBC_FOUND)
list (APPEND OPTIONAL_DLLS "${ILBC_DLL_DIR}/${ILBC_DLL}")
endif(ILBC_FOUND)
+ if (OPUS_FOUND)
+ list (APPEND OPTIONAL_DLLS "${OPUS_DLL_DIR}/${OPUS_DLL}")
+ endif(OPUS_FOUND)
if (LIBXML2_FOUND)
foreach( _dll ${LIBXML2_DLLS} )
list (APPEND OPTIONAL_DLLS "${LIBXML2_DLL_DIR}/${_dll}")
@@ -3037,6 +3052,9 @@ if(RPMBUILD_EXECUTABLE)
if (ILBC_FOUND)
list(APPEND _rpmbuild_with_args --with ilbc)
endif()
+ if (OPUS_FOUND)
+ list(APPEND _rpmbuild_with_args --with opus)
+ endif()
if (LIBXML2_FOUND)
list(APPEND _rpmbuild_with_args --with libxml2)
endif()