aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJohn Thacker <johnthacker@gmail.com>2020-11-26 06:10:34 +0000
committerGuy Harris <gharris@sonic.net>2020-12-19 22:41:57 +0000
commit5c1c84f4159278dd9655dbf40017a40f15a94b02 (patch)
tree2a6fe32da9adcc4996a9509d47708a0838f4200a /CMakeLists.txt
parent6e6b4c9e7a859058f9d26053785f2c38d6bf032d (diff)
macOS: Enable PKCS #11 support when building with macos-setup.sh
Enable PKCS #11 support in macOS builds with macos-setup.sh (already supported on macOS via Homebrew and on all other OSes with GnuTLS 3.4 or greater) by installing p11-kit (and its dependency libtasn1) and building nettle and GnuTLS against it. (cherry picked from commit fe1f9475409f252b6ca2dccc71187868e168c74b)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 4 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 2ffc161073..e027c0a0e2 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1237,11 +1237,11 @@ add_custom_target(dist
)
if(GNUTLS_FOUND AND NOT GNUTLS_VERSION VERSION_LESS "3.4.0")
- # While all Linux and Windows builds have PKCS #11 support enabled,
- # macos-setup.sh explicitly disables it using --without-p11-kit.
+ # Calculating public keys from PKCS #11 private keys requires GnuTLS
+ # 3.4.0 or greater.
#
- # Require at least GnuTLS 3.4.0 such that public keys can be calculated
- # from PKCS #11 private keys.
+ # Check that the support is present in case GnuTLS was compiled
+ # --without-p11-kit as macos-setup.sh did until recently.
include(CheckSymbolExists)
cmake_push_check_state()
if(WIN32)