aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJörg Mayer <jmayer@loplof.de>2009-09-08 16:07:14 +0000
committerJörg Mayer <jmayer@loplof.de>2009-09-08 16:07:14 +0000
commit443f384fef6c1066926832cc1d10e76e23098c53 (patch)
tree1c3c6e727cafbc5421ef81d622476cf2bbf96048 /CMakeLists.txt
parent1aca48909c80eb9cf14eb25f9a83909d3a581dd4 (diff)
Build new packetlist
svn path=/trunk/; revision=29800
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt10
1 files changed, 7 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b2bfcd591d..3f65bc0407 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -77,16 +77,20 @@ if(ENABLE_EXTRA_GCC_CHECKS)
-pedantic -Wstrict-prototypes -Wmissing-declarations -Wwrite-strings)
endif()
+add_definitions(
+ -DHAVE_CONFIG_H
+ -DPACKAGE=\"wireshark\"
+ -DNEW_PACKET_LIST
+)
+
if(CMAKE_COMPILER_IS_GNUCC)
add_definitions(
- -DHAVE_CONFIG_H
-D_U_=__attribute__\(\(unused\)\)
- -DPACKAGE=\"wireshark\"
-Wall -Wpointer-arith -W
${WIRESHARK_EXTRA_GCC_FLAGS}
)
else()
- add_definitions(-DPACKAGE=\"wireshark\" -DHAVE_CONFIG_H -D_U_=\"\")
+ add_definitions(-D_U_=\"\")
endif()
#The minimum package list