aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGerald Combs <gerald@wireshark.org>2020-03-03 08:28:39 -0800
committerGerald Combs <gerald@wireshark.org>2020-03-03 17:22:30 +0000
commit290ddeeed4947d88a5cb8f13e500a3ff67783e22 (patch)
tree67be43210ec19a9c867085379aca75a3579b2538 /CMakeLists.txt
parent9f3a335f459de8ac4eb5521f2c7e1820e95e2dfe (diff)
macOS: Make the dmg_package target fail noisily.
Change-Id: I479c9f13b9695d78d47b698a14cda0989724c639 Reviewed-on: https://code.wireshark.org/review/36270 Petri-Dish: Gerald Combs <gerald@wireshark.org> Tested-by: Petri Dish Buildbot Reviewed-by: Dario Lombardo <lomato@gmail.com> Tested-by: Dario Lombardo <lomato@gmail.com> Reviewed-by: Gerald Combs <gerald@wireshark.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt54
1 files changed, 26 insertions, 28 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 331ce349f3..fed8fbd843 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -2916,34 +2916,32 @@ if(ENABLE_APPLICATION_BUNDLE)
)
add_dependencies(app_bundle ${PROGLIST} chmodbpf path_helper)
- if( DMGBUILD_EXECUTABLE AND ASCIIDOCTOR_FOUND)
- add_custom_target(dmg_package_prep DEPENDS app_bundle)
-
- set(_read_me_first "packaging/macosx/Read me first.html")
- ADD_CUSTOM_COMMAND(
- OUTPUT
- ${_read_me_first}
- COMMAND ${ASCIIDOCTOR_EXECUTABLE}
- --backend html
- --out-file ${_read_me_first}
- --attribute include-dir=${CMAKE_SOURCE_DIR}/docbook
- --attribute min-macos-version=${MIN_MACOS_VERSION}
- ${CMAKE_CURRENT_SOURCE_DIR}/packaging/macosx/Read_me_first.adoc
- DEPENDS
- ${CMAKE_CURRENT_SOURCE_DIR}/packaging/macosx/Read_me_first.adoc
- )
- add_custom_target(read_me_first_html DEPENDS ${_read_me_first} )
- add_dependencies(dmg_package_prep read_me_first_html)
-
- ADD_CUSTOM_TARGET( dmg_package
- COMMAND bash -x ${CMAKE_BINARY_DIR}/packaging/macosx/osx-dmg.sh
- # Unlike nsis_package_prep + nsis_package, we can add a direct
- # dependency here.
- DEPENDS dmg_package_prep
- # We create Wireshark.app in "run". Do our work there.
- WORKING_DIRECTORY ${CMAKE_BINARY_DIR}/run
- )
- endif()
+ add_custom_target(dmg_package_prep DEPENDS app_bundle)
+
+ set(_read_me_first "packaging/macosx/Read me first.html")
+ ADD_CUSTOM_COMMAND(
+ OUTPUT
+ ${_read_me_first}
+ COMMAND ${ASCIIDOCTOR_EXECUTABLE}
+ --backend html
+ --out-file ${_read_me_first}
+ --attribute include-dir=${CMAKE_SOURCE_DIR}/docbook
+ --attribute min-macos-version=${MIN_MACOS_VERSION}
+ ${CMAKE_CURRENT_SOURCE_DIR}/packaging/macosx/Read_me_first.adoc
+ DEPENDS
+ ${CMAKE_CURRENT_SOURCE_DIR}/packaging/macosx/Read_me_first.adoc
+ )
+ add_custom_target(read_me_first_html DEPENDS ${_read_me_first} )
+ add_dependencies(dmg_package_prep read_me_first_html)
+
+ ADD_CUSTOM_TARGET( dmg_package
+ COMMAND bash -x ${CMAKE_BINARY_DIR}/packaging/macosx/osx-dmg.sh
+ # Unlike nsis_package_prep + nsis_package, we can add a direct
+ # dependency here.
+ DEPENDS dmg_package_prep
+ # We create Wireshark.app in "run". Do our work there.
+ WORKING_DIRECTORY ${CMAKE_BINARY_DIR}/run
+ )
endif()