aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGerald Combs <gerald@wireshark.org>2019-12-18 09:33:23 -0800
committerGerald Combs <gerald@wireshark.org>2019-12-18 17:35:49 +0000
commitfd6cf89f21737cf11ab06bd5b77fb6cea4356f17 (patch)
treec365ce1f7c01a06faa3e434462ad2e8e23b562ea /CMakeLists.txt
parentb044c5f1de14dc7b8fb54d431f2a695aafe6669a (diff)
macOS: More ChmodBPF signing updates.
Run osx-extras.sh before building the ChmodBPF installer package. Change-Id: Iec3f88da86e48b5aac385369c7e68f23babc4c34 Reviewed-on: https://code.wireshark.org/review/35491 Reviewed-by: Gerald Combs <gerald@wireshark.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b62ec2a870..1bbca2fa24 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -2770,6 +2770,7 @@ if(ENABLE_APPLICATION_BUNDLE)
# a signed ChmodBPF script.
set (install_chmodbpf_component_pkg "${CMAKE_BINARY_DIR}/install.ChmodBPF.pkg")
add_custom_command(OUTPUT "${install_chmodbpf_component_pkg}"
+ COMMAND "${CMAKE_SOURCE_DIR}/packaging/macosx/osx-extras.sh"
COMMAND pkgbuild
--identifier org.wireshark.ChmodBPF.pkg
--version 1.1