aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMichael Mann <mmann78@netscape.net>2014-01-08 04:35:28 +0000
committerMichael Mann <mmann78@netscape.net>2014-01-08 04:35:28 +0000
commitbf284da2eef917f8bf55be3aad15bb296072bb77 (patch)
treefbf66f67fb32e3d49466867e62a1c07a03300283 /CMakeLists.txt
parenta6ed8a1de97a70668a8feaeade2a11cc4c93185f (diff)
TFShark (Terminal Fileshark) v.001. Bug 9607 (https://bugs.wireshark.org/bugzilla/show_bug.cgi?id=9607)
This is a VERY PRELIMINARY version of tfshark. It's an attempt to jumpstart FileShark and its architecture. Right now it's mostly just a very stripped down version of tshark with all of the necessary build modifications (including now building filetap library since tfshark depends on it) This code has helped me identify what I believe to be all of the necessary layers for a complete fileshark architecture. And those layers will slowly be added in time (patches always welcome!). svn path=/trunk/; revision=54646
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt26
1 files changed, 25 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c735af1938..5c4938886e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -818,7 +818,6 @@ set(SHARK_COMMON_CAPTURE_SRC
set(WIRESHARK_COMMON_SRC
${PLATFORM_CAPTURE_SRC}
capture-pcap-util.c
- cfile.c
cfutils.c
clopts_common.c
frame_tvbuff.c
@@ -944,6 +943,7 @@ if( (BUILD_wireshark AND GTK_FOUND) OR (BUILD_qtshark AND QT_FOUND) )
proto_hier_stats.c
summary.c
ws80211_utils.c
+ cfile.c
${SHARK_COMMON_CAPTURE_SRC}
${WIRESHARK_COMMON_SRC}
${PLATFORM_UI_SRC}
@@ -1016,6 +1016,7 @@ if(BUILD_tshark)
capture_sync.c
tshark-tap-register.c
tshark.c
+ cfile.c
${TSHARK_TAP_SRC}
${SHARK_COMMON_CAPTURE_SRC}
${WIRESHARK_COMMON_SRC}
@@ -1028,6 +1029,28 @@ if(BUILD_tshark)
install(TARGETS tshark RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR})
endif()
+if(BUILD_tfshark)
+ set(tfshark_LIBS
+ ui
+ ${LIBEPAN_LIBS}
+ ${APPLE_CORE_FOUNDATION_LIBRARY}
+ ${APPLE_SYSTEM_CONFIGURATION_LIBRARY}
+ )
+ set(tfshark_FILES
+ tfshark.c
+# tfshark-tap-register.c
+ ${TSHARK_TAP_SRC}
+ ${SHARK_COMMON_CAPTURE_SRC}
+ ${WIRESHARK_COMMON_SRC}
+ )
+ add_executable(tfshark ${tfshark_FILES})
+ add_dependencies(tfshark svnversion)
+ set_target_properties(tfshark PROPERTIES LINK_FLAGS "${WS_LINK_FLAGS}")
+ set_target_properties(tfshark PROPERTIES FOLDER "Executables")
+ target_link_libraries(tfshark ${tfshark_LIBS})
+ install(TARGETS tfshark RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR})
+endif()
+
if(BUILD_rawshark AND PCAP_FOUND)
set(rawshark_LIBS
${LIBEPAN_LIBS}
@@ -1035,6 +1058,7 @@ if(BUILD_rawshark AND PCAP_FOUND)
${APPLE_SYSTEM_CONFIGURATION_LIBRARY}
)
set(rawshark_FILES
+ cfile.c
${WIRESHARK_COMMON_SRC}
rawshark.c
ui/util.c