aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDario Lombardo <lomato@gmail.com>2019-08-27 14:49:13 +0100
committerAnders Broman <a.broman58@gmail.com>2019-08-27 15:50:40 +0000
commita1532e7b16abf9912fae50a1ac50bcc8a53149aa (patch)
tree80d0e25c148130d6f20094f9ad3d69514f117d8a /CMakeLists.txt
parentb3f67fa1fa40d617bdcdf4fcae694b02d00f4562 (diff)
cmake: check minimum zstd library version.
The APIs used in the kafka dissector have been introduced in version 1.0.0, then we need at least that version to work. Change-Id: I80ded2362d4f324ec26392bd7a9781ea6d9ba630 Reviewed-on: https://code.wireshark.org/review/34382 Petri-Dish: Dario Lombardo <lomato@gmail.com> Tested-by: Petri Dish Buildbot Reviewed-by: Anders Broman <a.broman58@gmail.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 01d68b8890..c28d909197 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1139,7 +1139,7 @@ ws_find_package(LZ4 ENABLE_LZ4 HAVE_LZ4)
ws_find_package(SNAPPY ENABLE_SNAPPY HAVE_SNAPPY)
# zstd compression
-ws_find_package(ZSTD ENABLE_ZSTD HAVE_ZSTD)
+ws_find_package(ZSTD ENABLE_ZSTD HAVE_ZSTD "1.0.0")
# Enhanced HTTP/2 dissection
ws_find_package(NGHTTP2 ENABLE_NGHTTP2 HAVE_NGHTTP2)