aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorTomasz Moń <desowin@gmail.com>2019-09-15 11:25:18 +0200
committerPeter Wu <peter@lekensteyn.nl>2019-09-21 08:51:34 +0000
commit893a2d9c62e8dcc4fe0f43c47e01743136f55386 (patch)
treed42803e115b676b08c0a659df75390554d2b53b9 /CMakeLists.txt
parent29be7f9d9a6452a63cb22c425ac1c56d1f99f10d (diff)
MSVC: Warn about unused formal parameters
Provide _U_ macro definition for Visual Studio. Change the way _U_ macro is ifdefed for some targets to allow Visual Studio to recognize it. Ping-Bug: 15832 Change-Id: Ic7ce145cbe9e8aa751d64c9c09ce8ba6c1bbbd30 Reviewed-on: https://code.wireshark.org/review/34530 Tested-by: Petri Dish Buildbot Petri-Dish: Peter Wu <peter@lekensteyn.nl> Reviewed-by: Peter Wu <peter@lekensteyn.nl>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d97f19424b..faa463d0c6 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -427,10 +427,11 @@ if( CMAKE_C_COMPILER_ID MATCHES "MSVC")
# Additional compiler warnings to be treated as "Level 3"
# when compiling Wireshark sources. (Selected from "level 4" warnings).
## 4295: array is too small to include a terminating null character
+ ## 4100: unreferenced formal parameter
## 4189: local variable is initialized but not referenced
# Disable warnings about about use of flexible array members:
## 4200: nonstandard extension used : zero-sized array in struct/union
- list(APPEND LOCAL_CFLAGS /w34295 /w34189 /wd4200)
+ list(APPEND LOCAL_CFLAGS /w34295 /w34100 /w34189 /wd4200)
# We've matched these to specific compiler versions using the
# checks above. There's no need to pass them to check_c_compiler_flag