aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPeter Wu <peter@lekensteyn.nl>2020-01-29 22:29:05 +0000
committerAlexis La Goutte <alexis.lagoutte@gmail.com>2020-01-30 05:51:25 +0000
commit530e243c0928ae5c58e4449a1178852f2cc30020 (patch)
treec2c4874c04b138373b27f1a50cae7c348e302c2f /CMakeLists.txt
parent8c1e28c0b72e87031ce87ad350dddb5565c02f1e (diff)
CMake: look for libcap on Linux only
The feature is Linux-specific, do not suggest an unavailable feature on macOS and other systems. Change-Id: If53989749f571ace7397e288e9c06e357d0a96b2 Reviewed-on: https://code.wireshark.org/review/35985 Petri-Dish: Peter Wu <peter@lekensteyn.nl> Tested-by: Petri Dish Buildbot Reviewed-by: Alexis La Goutte <alexis.lagoutte@gmail.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 9b6d65d3bd..bd736ff6c1 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1173,9 +1173,9 @@ if(NOT LIBXML2_FOUND)
set(LIBXML2_INCLUDE_DIRS "")
endif()
-# Capabilities
-ws_find_package(CAP ENABLE_CAP HAVE_LIBCAP)
-if(NOT WIN32)
+# Capabilities to run dumpcap as non-root user.
+if(CMAKE_SYSTEM_NAME STREQUAL "Linux")
+ ws_find_package(CAP ENABLE_CAP HAVE_LIBCAP)
find_package(SETCAP)
endif()