aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGerald Combs <gerald@wireshark.org>2019-11-22 11:16:36 -0800
committerGerald Combs <gerald@wireshark.org>2019-11-23 22:45:59 +0000
commit451a241e50bd34ba097bd09a5f9f673170779aaf (patch)
treecd112515a1ddcd15fb73b1d124e7223d27b1988c /CMakeLists.txt
parent6a0b558ac1da13fffec560c1a522bafbe95517a1 (diff)
Add c-ares to the required library list.
Although c-ares support was techically optional, it was either on by default or required in all of our packaging. Go ahead and require it globally. C-ares is widely available and synchronous name resolution can easily result in a horrific user experience. Change-Id: Id67c797316ed6b8a0ab5052e55a43a1b9e2a2464 Reviewed-on: https://code.wireshark.org/review/35188 Petri-Dish: Gerald Combs <gerald@wireshark.org> Reviewed-by: Peter Wu <peter@lekensteyn.nl> Tested-by: Petri Dish Buildbot Reviewed-by: Gerald Combs <gerald@wireshark.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 6dea7dede0..a7e44bfeca 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1028,6 +1028,9 @@ reset_find_package(GTHREAD2)
find_package(GTHREAD2 REQUIRED)
reset_find_package(GCRYPT GCRYPT_ERROR_LIBRARY)
find_package(GCRYPT "1.4.2" REQUIRED)
+# C Asynchronous resolver
+reset_find_package(CARES)
+find_package(CARES "1.5.0" REQUIRED)
find_package(LEX REQUIRED)
find_package(YACC REQUIRED)
find_package(Perl REQUIRED)
@@ -1119,9 +1122,6 @@ ws_find_package(GNUTLS ENABLE_GNUTLS HAVE_LIBGNUTLS "3.2.0")
# Kerberos
ws_find_package(KERBEROS ENABLE_KERBEROS HAVE_KERBEROS)
-# C Asynchronous resolver
-ws_find_package(CARES ENABLE_CARES HAVE_C_ARES "1.5.0")
-
# Zlib compression
ws_find_package(ZLIB ENABLE_ZLIB HAVE_ZLIB)