aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJohn Thacker <johnthacker@gmail.com>2020-12-21 11:27:44 -0500
committerAndersBroman <a.broman58@gmail.com>2021-01-02 19:00:51 +0000
commitfbd3fb3138f925aa7af23b337bdf97ecf77b8a0a (patch)
treeb54af19a437a250f2b576cac3f4baaaf8c2577e8 /CMakeLists.txt
parentfd6c5e6a9beb150469d8151ad9c02a867a84f4c7 (diff)
GnuTLS: Bump minimum version to 3.3.0
Every supported distribution has at least the 3.3 branch of GnuTLS (stable branch starting in April 2014). That branch was maintained for bug-fixes until July 2018, so some distributions (e.g. RHEL7, SUSE Enterprise 12) are still on it, keeping us from requiring 3.4 yet. Also clarify a comment about when the Mac OS build of gnutls started being compiled with pkcs11 support.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 096d8836f4..23d4421593 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1132,7 +1132,7 @@ reset_find_package(SMI SMI_SHARE_DIR)
ws_find_package(SMI ENABLE_SMI HAVE_LIBSMI)
# Support for TLS decryption using RSA private keys.
-ws_find_package(GNUTLS ENABLE_GNUTLS HAVE_LIBGNUTLS "3.2.0")
+ws_find_package(GNUTLS ENABLE_GNUTLS HAVE_LIBGNUTLS "3.3.0")
# Kerberos
ws_find_package(KERBEROS ENABLE_KERBEROS HAVE_KERBEROS)
@@ -1239,7 +1239,7 @@ if(GNUTLS_FOUND AND NOT GNUTLS_VERSION VERSION_LESS "3.4.0")
# 3.4.0 or greater.
#
# Check that the support is present in case GnuTLS was compiled
- # --without-p11-kit as macos-setup.sh did until recently.
+ # --without-p11-kit as macos-setup.sh did until December 2020.
include(CheckSymbolExists)
cmake_push_check_state()
if(WIN32)