aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGraham Bloice <graham.bloice@trihedral.com>2021-04-10 19:15:34 +0100
committerGraham Bloice <graham.bloice@trihedral.com>2021-05-14 12:11:03 +0100
commitf6ad4812a2d8ee56b90fb204f00d54af27855992 (patch)
tree0173a6d55d84d6e2f0f18b027d7da8c235150c6c /CMakeLists.txt
parent2c62e2eb3ff1c700ccd79e6853f50aeac9832d8c (diff)
Add SparkplugB dissector
Add a dissector for SparkplugB as a heuristic subdissector of MQTT and which calls protobuf to dissect the messages payload.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt18
1 files changed, 18 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 3c4fd38cf6..04f3b03b5e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -2274,6 +2274,23 @@ add_custom_command(
WORKING_DIRECTORY "${CMAKE_SOURCE_DIR}"
)
+file(GLOB _protobuf_src_files RELATIVE "${CMAKE_SOURCE_DIR}" protobuf/*.proto)
+set (_protobuf_data_files)
+foreach(_data_file ${_protobuf_src_files})
+ list(APPEND _protobuf_data_files "${DATAFILE_DIR}/${_data_file}")
+endforeach()
+
+add_custom_command(
+ OUTPUT ${_protobuf_data_files}
+ COMMAND ${CMAKE_COMMAND} -E make_directory "${DATAFILE_DIR}/protobuf"
+ COMMAND ${CMAKE_COMMAND} -E copy_if_different
+ "${_protobuf_src_files}"
+ "${DATAFILE_DIR}/protobuf"
+ VERBATIM
+ DEPENDS ${_protobuf_src_files}
+ WORKING_DIRECTORY "${CMAKE_SOURCE_DIR}"
+)
+
file(GLOB _profiles_src_files RELATIVE "${CMAKE_SOURCE_DIR}" profiles/*/*)
set (_profiles_data_files)
foreach(_data_file ${_profiles_src_files})
@@ -2290,6 +2307,7 @@ list(APPEND copy_data_files_depends
${_dtds_data_files}
${_diameter_data_files}
${_radius_data_files}
+ ${_protobuf_data_files}
${_profiles_data_files}
)