aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMike78 <michael.oed@gmail.com>2014-12-20 23:13:05 +0100
committerMichael Mann <mmann78@netscape.net>2016-01-27 13:40:24 +0000
commitef752689da5cb948a6f40052342f597ee90bd0b6 (patch)
treecf22a118317bfba6bd2f3e12d12071b94ce306cb /CMakeLists.txt
parent522510060985eb9a59b22383636157a4cd199f89 (diff)
Allow/Create an option to use "capture filter" labels defined in wireshark GUI from CLI
Move ui/filters.[ch] to filter_files.[ch] because dumpcap is using functionality. Bug: 8091 Change-Id: I195c82fc023f97d6f331b8718c45a2d83d30faea Reviewed-on: https://code.wireshark.org/review/5925 Petri-Dish: Michael Mann <mmann78@netscape.net> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: Michael Mann <mmann78@netscape.net>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 50d645d183..90fde1e1a2 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1709,6 +1709,7 @@ if( (BUILD_wireshark AND QT_FOUND) OR (BUILD_wireshark_gtk AND GTK_FOUND) )
capture_opts.c
file.c
fileset.c
+ filter_files.c
summary.c
${SHARK_COMMON_SRC}
${PLATFORM_UI_SRC}
@@ -2066,6 +2067,7 @@ if(BUILD_tshark)
)
set(tshark_FILES
capture_opts.c
+ filter_files.c
tshark-tap-register.c
tshark.c
${TSHARK_TAP_SRC}
@@ -2278,6 +2280,7 @@ if(BUILD_dumpcap AND PCAP_FOUND)
capture_stop_conditions.c
conditions.c
dumpcap.c
+ filter_files.c
pcapio.c
ringbuffer.c
sync_pipe_write.c